Layer0 only supports Node.js version 14 and higher

If you do not have Node.js installed on your system, download and install it from the official Node.js v14.x downloads page. Select the download that matches your operating system and run the installer. Note that the installer for Node.js will also install npm.

Note that while you can use any version of Node.js >= 14 locally, your app will run in Node 14 when deployed to the Layer0 cloud. Therefore we highly suggest using Node 14 for all development.

To add Layer0 to an existing app, run the following:

npm i -g @layer0/cli
layer0 init

To create a new Layer0 app, run:

npm create layer0-app@latest

... or using yarn ...

yarn create layer0-app@latest